Chronique du dépannage d’un ordinateur très lent (netsvcs)

Il y a quelques jours, la fille de Monsieur S. m’appelle un peu catastrophée à propos de l’état de fonctionnement du PC de son père. Celui ci est en effet très très lent sur internet (le PC, hein…). Des amis et des dépanneurs lui ont dit qu’il n’y avait rien à faire, que ça venait de la ligne. Comme elle me fait confiance, elle me demande si je peux jeter un coup d’œil. Bien sûr que je peux !

Sur place, je commence par vérifier le débit de la ligne sur un autre ordi que je connais très bien et, oh surprise, tout va pour le mieux. Il est relié en ethernet par l’intermédiaire de boitiers CPL et la ligne a un débit tout à fait correct.

Première pensée, virus ou autre malware…Tentative d’installation d’un outil de diagnostique et de nettoyage, mais la machine est vraiment trop lente, pas moyen ! A vrai dire, j’ai rarement une machine fonctionnelle aussi ralentie.

Consultation du moniteur système , le CPU est occupé à 100%… Pas étonnant que ce soit lent ! Je regarde les processus en cours pour voir comment s’appelle l’intrus et comment lui faire sa fête. Rien à signaler. Toutefois, en cochant « Voir les processus de tous les utilisateurs », un processus système occupe bien 100% du CPU, svchost ! Je considère parfois Windows comme un virus, mais là, y’a de l’abus. Un virus malin se fait passer pour un service. Eh ben non, en regardant les services concernés par ce processus, il s’agit de plusieurs occurrences de netsvcs… Je n’ai pas la science infuse, alors je cherche !

Plusieurs causes possibles, mais au vu de l’utilisation de Monsieur S. Et de sa propension à débrancher l’ordi quand ça l’agace, j’entreprends deux actions.

  1. Tout mettre à jour… Il y a 147 mises à jour en attente, dont certaines assez volumineuses. Ca prend du temps, beaucoup de temps… Mais je suis patient, très patient ! (c’est souvent préférable…) Ca finit par se faire, au bout de 6 heures, mais ça finit par se faire !
  2. Vider les journaux d’événements ! Un petit passage dans eventvwr.exe et je vide les différents journaux un peu saturés, forcément…

Quelques heures plus tard, donc, le CPU est revenu à un taux d’utilisation normal et par acquis de conscience, j’ai pu passer un diagnostique, faire un peu de nettoyage, passer l’antivirus mais rien de grave à signaler.

Aujourd’hui, Monsieur S est content d’avoir retrouvé des performances raisonnables et m’a promis de ne plus débrancher mais d’attendre l’installation des mises à jour (c’est un peu pénible, je sais, mais c’est un mal nécessaire, la patience… pour les mises à jour, parfois je me demande)